ModelBuilder – Tools and Iterators
Models in the ArcGIS environment are used to automate geoprocessing workflows, and are often used to
perform repetitive tasks. Models can be saved to a toolbox for reuse, and can be executed as needed. This
guide provides a generic example of using ModelBuilder to create feature classes to assist beginners with
navigating the ModelBuilder window. This example also includes the use of an iterator and inline variables to
demonstrate the concepts of model-only tools and variable substitution.
Note: The text files used in this example can be found as Appendix 1 and 2 of this document. If you wish to
follow along using the example files, simply copy/paste each file to Notepad or a similar text editor and save the
text files to a folder on your local machine, ensuring that there are no spaces in the path and file names.
Step 1 Set up your work environment
1. Open ArcMap to a new document and launch ArcCatalog from the main menu
. ArcMap has a
property called the default geodatabase, which marks the location where outputs from tools and
models are to be stored. The default geodatabase (Default.gdb) is created automatically when a user
installs ArcGIS software, and is usually located in the My Documents > ArcGIS folder on Windows
machines. This property can be changed to any drive or directory you wish to use.
It is recommended that you set up a default geodatabase for your model. This is especially useful when
running an iterative model with many outputs. The default geodatabase will keep your outputs
organized, and having this default path set in advance will save time and ensure that you know exactly
where your results are stored.
2. In the ArcCatalog window, browse to the workspace where you wish to save your data. If you are
unable to see the drive or folder in the Catalog tree, use the Connect to Folder button to establish a
connection with your workspace. Right-click the workspace and select New > File Geodatabase. Enter a
descriptive name and click OK to create the database. Then, right-click the new geodatabase and select
Make Default Geodatabase.
Note: You must have full permissions (read, write, etc.) on the folder where you create your file
geodatabase. If you do not have write access to this folder then the geoprocessing tools will not be able
to save the outputs to this location, and the tools will fail.
3. Save the map document.
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Step 2 Add tools and parameters to ModelBuilder
Launch ArcToolbox
a new, blank model.

and ModelBuilder

from the main menu in ArcMap. The model window will open to

In this example we will build a workflow to create point feature classes from coordinate values stored in text
files. We will create an iterative process, meaning that we will structure the model to repeat the workflow for
each file stored in the associated directory. In other words, the model will iterate through the files in a folder
and execute the geoprocessing tasks for each one in the order that they are encountered.
In ArcToolbox, browse to the Data Management Tools > Layers and Table Views toolbox. Select the Make XY
Event Layer tool, hold down the mouse button and drag the tool into the Model window. The tool will appear as
a white rectangle connected to its output.

Note: You can resize the Model window using the bottom right corner of the dialog.
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Double-click the Make XY Event Layer tool in the Model window and fill in the associated parameter as follows.
1. Set the XY Table to the file or table containing the coordinate data.
2. Set the X Field to the column that contains longitude values (Field8 in the example files).
3. Set the Y Field to the column that contains latitude values (Field 7 in the example files).
4. Set the Z Field to the column that contains elevation values, if applicable.
5. Set the Spatial Reference to the coordinate system used to collect the coordinate values, if known.
Click OK to close the tool dialog and return to the Model window.
Note: ModelBuilder uses colours to indicate the status of tools and variables. A white shape indicates that the
tool still requires information from the user before it can be executed. Note that the Make XY Event Layer tool is
now coloured after filling in the tool parameters, which means that the tool can be launched at any time. Blue
represents inputs, yellow represents tools, and green represents outputs.

Step 3 Iteration
As mentioned, this model will be an iterative workflow. There are several iteration methods available within
ModelBuilder, all of which can be accessed via the Insert menu in the Model window. Descriptions and help
documentation for each iterator are available here.
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There is often more than one method to accomplish a task in ArcGIS. In this example our data is stored as text
files in a folder and holds coordinate value information that we wish to convert to a spatial layer. There are two
separate methods that will allow us to achieve our results; using the Iterate Tables iterator, or using the built-in
Python list logic. Both of these processes are explained thoroughly in the remainder of this guide.
3a. Python List Logic
First, set the tool’s input as a list – this tells the software that there will be multiple inputs to the tool. Rightclick the blue input oval and select Properties from the hidden menu. Under General, ensure that the option ‘A
list of values’ is checked and then click OK. The input and output will now display as multiple stacked shapes.

Double-click the blue input to open the batch processing grid. This grid displays an entry for each list item that
you wish to process. Initially, you will see only the first input. Double-click the row number to view its
properties.
Click the + sign to add another item to the list and
browse to the directory where your files are stored.
Select the second file in the list to enter it to the
grid. Repeat this step for each table you wish to
process. In our example, we will be using only two
files, which makes the batch processing grid a quick
and easy method for iteration. However, if you are
attempting to run the model on a relatively large
number of files then this method can quickly
become time-consuming. In this case, it may be a
better option to use one of the built-in iterators.
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3b. Iterate Tables
Access the Insert > Iterators menu and select the Iterate Tables option to add the process to the Model window.
Double-click the Iterate Tables process and enter the parameters as follows.
1. Set the Workspace to the directory where the files to be processed are stored.
2. Set the Wildcard parameter if you wish to restrict the model to iterate through files that have a specific
word or character. If this is left blank then all of the files within the directory will be processed.
3. Set the Table Type parameter if you wish to restrict the model to iterate through specific file types. For
example, entering DBF here will ensure that the model only processes DBF files. If this parameter is left
blank then the tool will attempt to process all valid file types within the directory.

At this point, you can go ahead and delete the input to the Make XY Event Layer tool that we created in Step 2.
Instead, double-click the Make XY Event Layer tool to open its parameters and click the drop down arrow beside
the XY Table parameter and select the iterative list of tables
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The iterator and tool should now be connected, with the iterator’s output file acting as the input for the Make
XY Event Layer tool.

Step 4 Add Processes
The first iterative process in our model is now complete and ready to execute. However, our end goal with this
model is to create feature classes from the coordinate information stored in our text files. The Make XY Event
Layer tool creates a temporary event layer for our point data. To subsequently create a permanent feature
class, we will use the Copy Features tool.
In ArcToolbox, browse to Data Management Tools > Features and drag the Copy Features tool to the Model
window. Double-click the Copy Features tool to open its dialog and set the parameters as follows.
1. Set the Input Features to the output from the Make XY Event Layer process.
2. Set the Output Feature Class to the path where you wish to store your final outputs.

Note: This example uses inline variable substitution to provide a name for the output feature class. As seen in
the model examples, the Name variable is created via the Iterate Tables tool. Each time the tool moves through
an iteration, the variable is populated with the name of the file that is currently being processed. Use of inline
variable substitution in this case insures that each file has a unique name that will allow us to identify the
outputs later. In our example, the first time the model iterates through, the Name variable is populated with
the filename 0403. Thus, our final output will be CF_0403. The second iteration processes a file called 0406.txt
– so our next output will be CF_0406, etc. More information can be found here.
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Step 5 Set Parameters
Model parameters are those that will be set by the user during runtime. That is, since models are designed for
reuse, you will likely incorporate inputs that must be set by the user each time the model is run. For example, in
our model we will ask the user to set the input workspace for the Iterate Tables tool. To set a model parameter,
simply right-click the input/s that will be asked for from the user and select Model Parameter from the hidden
menu. A ‘P’ will appear beside the selected input, indicating that it has been designated as a model parameter.
The model will now prompt the user for this parameter before execution.

Step 6 Save and Run the Model
To save your model, click the Save button
in the Model window and either browse to an existing toolbox or
use the tools provided in the Save dialog to create a new toolbox.

Note: Models must be saved to a
toolbox. You can choose to save the
model to an existing toolbox, or
alternatively there is a default My
Toolboxes workspace available in the
Catalog tree. You may also choose to
create a new toolbox in a workspace of
your choice (right-click > New > Toolbox).
You must have full permissions
(specifically write access) to the
directory where your toolboxes and
models are saved.

To run the model, click the Run button
from the Model window. If you are attempting to edit or run the
model after it has been closed, simply browse to the toolbox in ArcCatalog, right-click the model and select Edit
or Run. A drop shadow will appear behind the tools and inputs/outputs that have completed successfully, as
shown below.
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Our example model iterates through two text files in the specified workspace and subsequently creates two
feature classes within the directory we have chosen for our outputs. The inline variable substitution insures
that each file is named uniquely according to the original tables, as shown below.

Although it is by no means an exhaustive manual, this guide attempts to illustrate some of the basic concepts
employed when using ModelBuilder to create reusable, iterative workflows. Shortened versions of the example
text files used to create and test this model have been provided as appendices to this document. Simply copy
the text for each file into Notepad or a similar text editor and save the files to your local drive. Then, build the
model as instructed and substitute the paths and variables for your local directory paths and filenames
accordingly.

For further assistance with this guide or other topics related to geospatial and/or statistical data and
software, please contact us at madgichelp@trentu.ca.
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Appendix A: File 0403.txt
1999 04 03 01 04 33.912822700 +42.5060 -093.7287 -025.8 01 1
1999 04 03 01 15 40.107793500 +42.4444 -093.9771 -027.2 04 1
1999 04 03 01 15 46.200932003 +42.8121 -093.1627 -032.8 01 1
1999 04 03 01 23 29.853438798 +42.4936 -093.9029 -017.3 01 1
1999 04 03 01 25 40.042725900 +42.4768 -093.8548 -013.6 01 1
1999 04 03 01 28 29.075882600 +42.5037 -093.8264 -018.5 01 1
1999 04 03 01 29 20.099120300 +42.5363 -093.8548 -012.9 02 1
1999 04 03 01 30 19.254680000 +42.5435 -093.8510 -010.7 04 1
1999 04 03 01 36 23.243391500 +42.5923 -093.7545 -008.9 03 1
1999 04 03 01 37 14.577770800 +42.7663 -093.7553 -009.9 01 1
1999 04 03 01 37 45.314093900 +42.6028 -093.7475 -011.7 01 1
1999 04 03 01 38 18.935099500 +42.7518 -093.7838 +029.4 01 1
1999 04 03 01 39 41.784227200 +42.7665 -093.7481 -011.1 01 1
1999 04 03 01 43 09.668299500 +42.6205 -093.6672 -014.1 01 1
1999 04 03 01 43 38.996174933 +42.8336 -093.6911 -035.1 01 1
1999 04 03 01 46 36.000637600 +42.6273 -093.6221 -024.4 01 1
1999 04 03 01 47 00.390527000 +42.4202 -093.4523 +052.8 01 1
1999 04 03 01 47 00.406475900 +42.4162 -093.3271 +015.7 01 1
1999 04 03 01 47 51.699056751 +42.6814 -093.5888 -036.7 01 1
1999 04 03 01 48 44.254979400 +42.6616 -093.6389 -011.5 03 1
1999 04 03 01 52 57.793299357 +42.7355 -093.5962 +021.7 01 1
1999 04 03 01 55 10.415199500 +42.3759 -093.3489 +097.6 01 1
1999 04 03 01 55 10.415309300 +42.5082 -093.2660 -038.8 01 1
1999 04 03 01 58 00.623073800 +42.8008 -093.6594 -009.4 01 1
1999 04 03 02 02 14.759010247 +42.7865 -093.5401 -011.0 02 1
1999 04 03 02 03 13.194023299 +42.5197 -093.4296 -016.9 01 1
1999 04 03 02 04 22.557588300 +42.8053 -093.5265 -009.3 02 1
1999 04 03 02 06 44.614494900 +42.4129 -093.3108 +066.5 01 1
1999 04 03 02 08 46.097705900 +43.1028 -093.4602 +024.7 01 2
1999 04 03 02 10 37.802899600 +42.5709 -093.7114 -017.1 02 1
1999 04 03 02 11 11.595139100 +42.8292 -093.3883 -010.5 01 1
1999 04 03 02 12 01.212328400 +42.8166 -093.3647 -015.1 01 1
1999 04 03 02 12 01.801661332 +42.8271 -093.3958 -012.5 01 1
1999 04 03 02 15 10.277733900 +42.0418 -093.8809 +023.0 01 1
1999 04 03 02 16 00.149242800 +42.4864 -093.2807 +077.0 01 1
1999 04 03 02 17 18.027795400 +42.8497 -093.3059 -020.0 02 1
1999 04 03 02 17 49.778184500 +42.4526 -093.2206 -016.1 01 1
1999 04 03 02 18 07.512454200 +42.8612 -093.3100 -019.4 01 1
1999 04 03 02 20 45.278923400 +42.2176 -093.8554 +035.0 01 1
1999 04 03 02 22 09.775696900 +42.8937 -093.2740 -017.1 01 1
1999 04 03 02 25 40.724709971 +42.9133 -093.2330 -016.1 01 1
1999 04 03 02 26 12.304497703 +43.4049 -093.8804 +031.9 01 1
1999 04 03 02 26 27.354347700 +42.9297 -093.2102 -013.7 02 1
1999 04 03 02 26 47.354006900 +42.1808 -093.7886 -016.0 01 1
1999 04 03 02 26 47.902807200 +42.1909 -093.7412 +048.5 01 1
1999 04 03 02 27 01.755185600 +42.6499 -093.0230 -006.6 01 1
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Appendix B: File 0406.txt
2010 04 06 00 00 02.411294097 +40.2549 -085.5296 -010.7 02 1
2010 04 06 00 00 19.965478037 +42.4777 -091.1379 -019.6 01 2
2010 04 06 00 00 19.965478037 +42.4777 -091.1380 -019.6 01 2
2010 04 06 00 00 19.983470471 +42.4736 -091.1389 -011.4 15 1
2010 04 06 00 00 20.148439435 +42.4752 -091.1586 +014.2 01 2
2010 04 06 00 00 20.807551419 +42.4728 -091.1558 -011.6 02 1
2010 04 06 00 00 31.450108329 +42.2048 -090.4131 -017.0 01 1
2010 04 06 00 00 41.449866466 +40.2448 -085.6559 +013.9 01 2
2010 04 06 00 00 48.397440391 +42.4916 -091.1666 +005.3 01 2
2010 04 06 00 00 48.397441891 +42.4894 -091.1560 +005.3 01 2
2010 04 06 00 00 52.775416614 +43.1999 -090.3816 -014.1 01 2
2010 04 06 00 00 53.106380884 +43.1663 -090.4237 +076.8 01 1
2010 04 06 00 01 03.864217924 +42.3329 -090.4455 -011.9 02 1
2010 04 06 00 01 05.169031488 +40.2691 -085.5085 -023.7 02 1
2010 04 06 00 01 06.558655005 +40.0119 -084.4270 +009.7 01 2
2010 04 06 00 01 10.543952101 +42.3640 -091.1775 +004.5 01 2
2010 04 06 00 01 10.543952401 +42.3635 -091.1748 +004.5 01 2
2010 04 06 00 01 10.657296146 +42.4211 -091.2040 +007.8 01 2
2010 04 06 00 01 10.657297446 +42.4260 -091.2041 +007.8 01 2
2010 04 06 00 01 23.477187364 +42.5169 -091.2189 -014.4 01 2
2010 04 06 00 01 38.806107508 +40.2582 -085.5171 -014.8 03 1
2010 04 06 00 01 51.851587138 +42.4003 -091.1743 +008.4 01 2
2010 04 06 00 01 51.851587138 +42.4003 -091.1745 +008.4 01 2
2010 04 06 00 02 07.434101226 +42.4907 -091.1095 +006.7 01 2
2010 04 06 00 02 07.434101226 +42.4907 -091.1096 +006.7 01 2
2010 04 06 00 02 07.443058037 +42.5108 -091.1878 +005.5 01 2
2010 04 06 00 02 07.443059937 +42.5078 -091.1742 +005.5 01 2
2010 04 06 00 02 07.937446791 +42.5404 -091.2291 +004.5 01 2
2010 04 06 00 02 17.562633246 +42.3221 -091.1435 -012.7 02 1
2010 04 06 00 02 32.044686498 +40.2809 -085.5143 -015.6 02 1
2010 04 06 00 02 40.751836940 +42.2899 -091.1666 -006.0 04 1
2010 04 06 00 02 55.336741599 +42.5428 -090.5459 +005.0 01 2
2010 04 06 00 02 58.220561062 +42.5093 -091.1083 -051.2 04 1
2010 04 06 00 02 58.248743323 +42.5186 -091.1044 -015.0 01 2
2010 04 06 00 02 58.248745123 +42.5137 -091.1096 -016.3 01 2
2010 04 06 00 02 58.769306417 +42.5152 -091.1060 -005.4 01 2
2010 04 06 00 02 58.993327683 +42.5267 -091.1138 -029.7 04 1
2010 04 06 00 03 00.183767264 +40.2778 -085.4637 -020.6 06 1
2010 04 06 00 03 14.664586343 +42.3672 -091.1396 +021.1 01 2
2010 04 06 00 03 15.030938446 +42.0963 -084.6437 -014.4 01 2
2010 04 06 00 03 15.031465678 +42.0915 -084.6579 -026.1 01 2
2010 04 06 00 03 35.954401658 +42.3808 -091.1775 +016.7 01 1
2010 04 06 00 03 35.987426833 +42.3683 -091.1622 -006.7 01 2
2010 04 06 00 03 35.987427133 +42.3679 -091.1600 -006.7 01 2
2010 04 06 00 03 36.540980376 +42.3539 -091.1379 -012.7 04 1
2010 04 06 00 03 36.616454430 +42.4106 -091.1122 +014.9 01 2
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